const regex = /[^>]*A(?=<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^>]*A(?=<)', 'gm')
const str = `<table class="prod-fit-info-table">
<tbody>
<tr class="tr -dark-grey">
<th class="td -outer">Make</th>
<th class="td -outer">Model</th>
<th class="td -outer">Year</th>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make A</td>
<td class="td">Model A</td>
<td class="td">Year A</td>
</tr>
<tr class="tr -grey -first">
<td class="td" rowspan="1">Make B</td>
<td class="td">Model B</td>
<td class="td">Year B</td>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make C</td>
<td class="td">Model C</td>
<td class="td">Year C</td>
</tr>
</tbody>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}