import Foundation
let pattern = #"[^>]*A(?=<)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<table class="prod-fit-info-table">
<tbody>
<tr class="tr -dark-grey">
<th class="td -outer">Make</th>
<th class="td -outer">Model</th>
<th class="td -outer">Year</th>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make A</td>
<td class="td">Model A</td>
<td class="td">Year A</td>
</tr>
<tr class="tr -grey -first">
<td class="td" rowspan="1">Make B</td>
<td class="td">Model B</td>
<td class="td">Year B</td>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make C</td>
<td class="td">Model C</td>
<td class="td">Year C</td>
</tr>
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)