# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^>]*A(?=<)"
test_str = ("<table class=\"prod-fit-info-table\">\n"
" <tbody>\n"
" <tr class=\"tr -dark-grey\">\n"
" <th class=\"td -outer\">Make</th>\n"
" <th class=\"td -outer\">Model</th>\n"
" <th class=\"td -outer\">Year</th>\n"
" </tr>\n"
" <tr class=\"tr -first\">\n"
" <td class=\"td\" rowspan=\"1\">Make A</td>\n"
" <td class=\"td\">Model A</td>\n"
" <td class=\"td\">Year A</td>\n"
" </tr>\n"
" <tr class=\"tr -grey -first\">\n"
" <td class=\"td\" rowspan=\"1\">Make B</td>\n"
" <td class=\"td\">Model B</td>\n"
" <td class=\"td\">Year B</td>\n"
" </tr>\n"
" <tr class=\"tr -first\">\n"
" <td class=\"td\" rowspan=\"1\">Make C</td>\n"
" <td class=\"td\">Model C</td>\n"
" <td class=\"td\">Year C</td>\n"
" </tr>\n"
"</tbody>\n"
"</table>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.