$re = '/[^>]*A(?=<)/m';
$str = '<table class="prod-fit-info-table">
<tbody>
<tr class="tr -dark-grey">
<th class="td -outer">Make</th>
<th class="td -outer">Model</th>
<th class="td -outer">Year</th>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make A</td>
<td class="td">Model A</td>
<td class="td">Year A</td>
</tr>
<tr class="tr -grey -first">
<td class="td" rowspan="1">Make B</td>
<td class="td">Model B</td>
<td class="td">Year B</td>
</tr>
<tr class="tr -first">
<td class="td" rowspan="1">Make C</td>
<td class="td">Model C</td>
<td class="td">Year C</td>
</tr>
</tbody>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);