#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\p{Cyrillic}\p{P}\p{S}\d\w\s]+"
Local $sString = "Kirill, [20.11.20 15:42]" & @CRLF & _
"[In reply to Гриша]" & @CRLF & _
"А её же много 😊 Нет-ли готового набора типа a-z, но для пунктуации (,.:- и проч.)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")