using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\p{Cyrillic}\p{P}\p{S}\d\w\s]+";
string input = @"Kirill, [20.11.20 15:42]
[In reply to Гриша]
А её же много 😊 Нет-ли готового набора типа a-z, но для пунктуации (,.:- и проч.)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}