package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\p{Cyrillic}\p{P}\p{S}\d\w\s]+`)
var str = `Kirill, [20.11.20 15:42]
[In reply to Гриша]
А её же много 😊 Нет-ли готового набор а типа a-z, но для пунктуации (,.:- и проч.)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}