const regex = /[\p{Cyrillic}\p{P}\p{S}\d\w\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{Cyrillic}\\p{P}\\p{S}\\d\\w\\s]+', 'gm')
const str = `Kirill, [20.11.20 15:42]
[In reply to Гриша]
А её же много 😊 Нет-ли готового набора типа a-z, но для пунктуации (,.:- и проч.)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}