import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{Cyrillic}\\p{P}\\p{S}\\d\\w\\s]+";
final String string = "Kirill, [20.11.20 15:42]\n"
+ "[In reply to Гриша]\n"
+ "А её же много 😊 Нет-ли готового набора типа a-z, но для пунктуации (,.:- и проч.)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}