$re = '/[\p{Cyrillic}\p{P}\p{S}\d\w\s]+/m';
$str = 'Kirill, [20.11.20 15:42]
[In reply to Гриша]
А её же много 😊 Нет-ли готового набора типа a-z, но для пунктуации (,.:- и проч.)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);