import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(\\.\\d+)?%)";
final String string = "Bachelor of Engineering in Electronics from in 2013 with 60%.\n"
+ "Diploma (Electronics & Video Engineering) from in 2009 with 79.39%.\n"
+ "SSC from in 2006 with 61.71%.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}