const regex = /(\d+(\.\d+)?%)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(\\.\\d+)?%)', 'g')
const str = `Bachelor of Engineering in Electronics from in 2013 with 60%.
Diploma (Electronics & Video Engineering) from in 2009 with 79.39%.
SSC from in 2006 with 61.71%.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}