$re = '/(\d+(\.\d+)?%)/';
$str = 'Bachelor of Engineering in Electronics from in 2013 with 60%.
Diploma (Electronics & Video Engineering) from in 2009 with 79.39%.
SSC from in 2006 with 61.71%.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);