import re
regex = re.compile(r"(\d+(\.\d+)?%)")
test_str = ("Bachelor of Engineering in Electronics from in 2013 with 60%.\n"
"Diploma (Electronics & Video Engineering) from in 2009 with 79.39%.\n"
"SSC from in 2006 with 61.71%.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")