using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|([\s\S]+?)\|";
string substitution = @"";
string input = @"машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}