const regex = /\|([\s\S]+?)\|/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|([\\s\\S]+?)\\|', 'g')
const str = `машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);