import re
regex = re.compile(r"\|([\s\S]+?)\|")
test_str = "машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)