import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^dev)|(^release\\/.*)|(^master)|(PR-\\d+)";
final String string = "dev\n"
+ "master\n"
+ "release/230444\n"
+ "defect/fix-it\n"
+ "chore/make-better\n"
+ "feature/click-it\n"
+ "PR-344\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}