$re = '/(^dev)|(^release\/.*)|(^master)|(PR-\d+)/m';
$str = 'dev
master
release/230444
defect/fix-it
chore/make-better
feature/click-it
PR-344
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);