const regex = /(^dev)|(^release\/.*)|(^master)|(PR-\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^dev)|(^release\\\/.*)|(^master)|(PR-\\d+)', 'gm')
const str = `dev
master
release/230444
defect/fix-it
chore/make-better
feature/click-it
PR-344
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}