import re
regex = re.compile(r"(^dev)|(^release\/.*)|(^master)|(PR-\d+)", flags=re.MULTILINE)
test_str = ("dev\n"
"master\n"
"release/230444\n"
"defect/fix-it\n"
"chore/make-better\n"
"feature/click-it\n"
"PR-344\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")