re = /(^dev)|(^release\/.*)|(^master)|(PR-\d+)/m
str = 'dev
master
release/230444
defect/fix-it
chore/make-better
feature/click-it
PR-344
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end