#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)matei 115 variables"
Local $sString = "<?php" & @CRLF & _
"$name = "Matei";" & @CRLF & _
"$age = 16;" & @CRLF & _
"$birthplace = "Klagenfurt";" & @CRLF & _
"$bench_pr = 95;" & @CRLF & _
"$five_k_pr = "23:51";" & @CRLF & _
"$running_distance = 5;" & @CRLF & _
"" & @CRLF & _
"echo "There was once someone named $name who was $age years of age. <br>" & @CRLF & _
" He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")