// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)matei 115 variables").unwrap();
let string = "<?php
$name = \"Matei\";
$age = 16;
$birthplace = \"Klagenfurt\";
$bench_pr = 95;
$five_k_pr = \"23:51\";
$running_distance = 5;
echo \"There was once someone named $name who was $age years of age. <br>
He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr\";
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}