using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"matei 115 variables";
string input = @"<?php
$name = ""Matei"";
$age = 16;
$birthplace = ""Klagenfurt"";
$bench_pr = 95;
$five_k_pr = ""23:51"";
$running_distance = 5;
echo ""There was once someone named $name who was $age years of age. <br>
He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr"";
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}