use strict;
my $str = '<?php
$name = "Matei";
$age = 16;
$birthplace = "Klagenfurt";
$bench_pr = 95;
$five_k_pr = "23:51";
$running_distance = 5;
echo "There was once someone named $name who was $age years of age. <br>
He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr";
';
my $regex = qr/matei 115 variables/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}