$re = '/matei 115 variables/m';
$str = '<?php
$name = "Matei";
$age = 16;
$birthplace = "Klagenfurt";
$bench_pr = 95;
$five_k_pr = "23:51";
$running_distance = 5;
echo "There was once someone named $name who was $age years of age. <br>
He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);