import re
regex = re.compile(r"matei 115 variables", flags=re.MULTILINE)
test_str = ("<?php\n"
"$name = \"Matei\";\n"
"$age = 16;\n"
"$birthplace = \"Klagenfurt\";\n"
"$bench_pr = 95;\n"
"$five_k_pr = \"23:51\";\n"
"$running_distance = 5;\n\n"
"echo \"There was once someone named $name who was $age years of age. <br>\n"
" He was born in $birthplace. He benched $bench_pr kg and ran $running_distance km in $five_k_pr\";\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")