using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3}(?:\.\d{3})*(?:,\d+)?$|^\d+(?:,)?\d+$";
string input = @"1.000,00
.000,00
.000.000,00
0.000,00
111
111,11
111.111,11
11.111.110,00
11.1111.11,00
111
11.11
1111.00
10111111,00
111.000,
11.111,00
111111,00
10.000,00000000
1000.100.00
1.000.000,00
12.345,67";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}