re = /^\d{1,3}(?:\.\d{3})*(?:,\d+)?$|^\d+(?:,)?\d+$/m
str = '1.000,00
.000,00
.000.000,00
0.000,00
111
111,11
111.111,11
11.111.110,00
11.1111.11,00
111
11.11
1111.00
10111111,00
111.000,
11.111,00
111111,00
10.000,00000000
1000.100.00
1.000.000,00
12.345,67'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end