import Foundation
let pattern = #"^\d{1,3}(?:\.\d{3})*(?:,\d+)?$|^\d+(?:,)?\d+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.000,00
.000,00
.000.000,00
0.000,00
111
111,11
111.111,11
11.111.110,00
11.1111.11,00
111
11.11
1111.00
10111111,00
111.000,
11.111,00
111111,00
10.000,00000000
1000.100.00
1.000.000,00
12.345,67
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)