import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3}(?:\\.\\d{3})*(?:,\\d+)?$|^\\d+(?:,)?\\d+$";
final String string = "1.000,00\n"
+ ".000,00\n"
+ ".000.000,00\n"
+ "0.000,00\n"
+ "111\n"
+ "111,11\n"
+ "111.111,11\n"
+ "11.111.110,00\n"
+ "11.1111.11,00\n"
+ "111\n"
+ "11.11\n"
+ "1111.00\n"
+ "10111111,00\n"
+ "111.000,\n"
+ "11.111,00\n"
+ "111111,00\n"
+ "10.000,00000000\n"
+ "1000.100.00\n"
+ "1.000.000,00\n"
+ "12.345,67";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}