using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\S+\s)?\S*IN\S*(?:\s(?:\(s*\S+\s*(?:,\s*\S+\s*)*\)|\S+))?";
string input = @"where c.value IN (3, 4, 5, 6)
where c.value IN (3,4,5,6)
where c.value IN (3)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}