import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\S+\\s)?\\S*IN\\S*(?:\\s(?:\\(s*\\S+\\s*(?:,\\s*\\S+\\s*)*\\)|\\S+))?";
final String string = "where c.value IN (3, 4, 5, 6)\n\n"
+ "where c.value IN (3,4,5,6)\n\n"
+ "where c.value IN (3)\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}