package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\S+\s)?\S*IN\S*(?:\s(?:\(s*\S+\s*(?:,\s*\S+\s*)*\)|\S+))?`)
var str = `where c.value IN (3, 4, 5, 6)
where c.value IN (3,4,5,6)
where c.value IN (3)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}