re = /(?:\S+\s)?\S*IN\S*(?:\s(?:\(s*\S+\s*(?:,\s*\S+\s*)*\)|\S+))?/
str = 'where c.value IN (3, 4, 5, 6)
where c.value IN (3,4,5,6)
where c.value IN (3)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end