using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d[^)]*\)";
string input = @"Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.
It is not supposed to match ( s s 1)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}