package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d[^)]*\)`)
var str = `Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.
It is not supposed to match ( s s 1)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}