import re
regex = re.compile(r"\b\d[^)]*\)", flags=re.MULTILINE)
test_str = ("Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.\n\n"
"Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.\n\n\n"
"Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.\n\n"
"It is not supposed to match ( s s 1) \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")