$re = '/\b\d[^)]*\)/m';
$str = 'Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.
It is not supposed to match ( s s 1)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);