const regex = /\b\d[^)]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d[^)]*\\)', 'gm')
const str = `Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1a b) demanding and 2a a) costly.
Programming is productive, (achieving a lot, and getting good results), it is often 1b) demanding and 2b) costly.
It is not supposed to match ( s s 1)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}