#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+\s+\w+(?:(?:\s\d+-\d+-\d+)?\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\.[a-z]+|\s\d+-\d+-\d+)"
Local $sString = "A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text" & @CRLF & _
"A lot of text... Second Name2 0723-333-444 ...a lot of text" & @CRLF & _
"A lot of text... Third Name3 email@address3.com ...a lot of text" & @CRLF & _
"A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text" & @CRLF & _
"A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")