using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s+\w+(?:(?:\s\d+-\d+-\d+)?\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\.[a-z]+|\s\d+-\d+-\d+)";
string input = @"A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text
A lot of text... Second Name2 0723-333-444 ...a lot of text
A lot of text... Third Name3 email@address3.com ...a lot of text
A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text
A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}