import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s+\\w+(?:(?:\\s\\d+-\\d+-\\d+)?\\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\\.[a-z]+|\\s\\d+-\\d+-\\d+)";
final String string = "A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text\n"
+ "A lot of text... Second Name2 0723-333-444 ...a lot of text\n"
+ "A lot of text... Third Name3 email@address3.com ...a lot of text\n"
+ "A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text\n"
+ "A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}