import Foundation
let pattern = #"\w+\s+\w+(?:(?:\s\d+-\d+-\d+)?\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\.[a-z]+|\s\d+-\d+-\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text
A lot of text... Second Name2 0723-333-444 ...a lot of text
A lot of text... Third Name3 email@address3.com ...a lot of text
A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text
A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)