package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\s+\w+(?:(?:\s\d+-\d+-\d+)?\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\.[a-z]+|\s\d+-\d+-\d+)`)
var str = `A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text
A lot of text... Second Name2 0723-333-444 ...a lot of text
A lot of text... Third Name3 email@address3.com ...a lot of text
A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text
A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}