import re
regex = re.compile(r"\w+\s+\w+(?:(?:\s\d+-\d+-\d+)?\s+[A-Za-z0-9.+_*-]+@[a-z0-9.+_-]+\.[a-z]+|\s\d+-\d+-\d+)", flags=re.MULTILINE)
test_str = ("A lot of text... First Name1 0723-111-222 email@address1.com ...a lot of text\n"
"A lot of text... Second Name2 0723-333-444 ...a lot of text\n"
"A lot of text... Third Name3 email@address3.com ...a lot of text\n"
"A lot of text... Fourth Name4 0723-777-888 email@address4.com ...a lot of text\n"
"A lot of text... Fifth Name5 0723-999-000 email@address5.com ...a lot of text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")