import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<(\\w+)\\s[^<>]+\\>(?!.*\\<\\/\\1\\>)";
final String string = "<img ng-src=\" {{getImageUrl('homeHelp64.jpg')}}\" alt=\"?\" width=\"16\" height=\"16\"/>\n"
+ " <test test-test=\"test\">\n"
+ " </test>\n"
+ "</img> // closed\n\n"
+ "<img ng-src=\" {{getImageUrl('homeHelp64.jpg')}}\" alt=\"?\" width=\"16\" height=\"16\"/>\n"
+ " <test test-test=\"test\">\n"
+ " </test>\n"
+ " // not closed\n\n"
+ "// group 1 saves tag name!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}