re = /\<(\w+)\s[^<>]+\>(?!.*\<\/\1\>)/
str = '<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16"/>
<test test-test="test">
</test>
</img> // closed
<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16"/>
<test test-test="test">
</test>
// not closed
// group 1 saves tag name!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end