import re
regex = re.compile(r"\<(\w+)\s[^<>]+\>(?!.*\<\/\1\>)", flags=re.DOTALL)
test_str = ("<img ng-src=\" {{getImageUrl('homeHelp64.jpg')}}\" alt=\"?\" width=\"16\" height=\"16\"/>\n"
" <test test-test=\"test\">\n"
" </test>\n"
"</img> // closed\n\n"
"<img ng-src=\" {{getImageUrl('homeHelp64.jpg')}}\" alt=\"?\" width=\"16\" height=\"16\"/>\n"
" <test test-test=\"test\">\n"
" </test>\n"
" // not closed\n\n"
"// group 1 saves tag name!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")